• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

88 XJ6 (XJ40) left turn & break lamps not working

jht1776
Posts: 5
Joined: Sun May 08, 2016 10:41 pm

88 XJ6 (XJ40) left turn & break lamps not working

Postby jht1776 » Mon Jul 04, 2016 10:00 pm

Hello, 1988 XJ left turn & break lamps not working, The lamp control module is good (switched with right side). I have power to the tail lamp but not to the turn stop lights, I checked fuses (good) , ground is good, I'm at a loss, any help would be appreciated, Thanks John

nlcrane
Spain Rep
Posts: 7597
Joined: Sun Feb 07, 2010 7:36 pm
Location: Spain

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby nlcrane » Mon Jul 04, 2016 10:31 pm

Try left fuse box, fuse number 7.
ImageImageImage
1994 Sovereign Gold 4.0

Area rep. SPAIN
espana.xj40@googlemail.com

jht1776
Posts: 5
Joined: Sun May 08, 2016 10:41 pm

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby jht1776 » Mon Jul 04, 2016 10:47 pm

Thanks, I'll check it again

nlcrane
Spain Rep
Posts: 7597
Joined: Sun Feb 07, 2010 7:36 pm
Location: Spain

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby nlcrane » Mon Jul 04, 2016 11:10 pm

jht1776 wrote:Thanks, I'll check it again


The left rear BFM is supplied via two different fuses, one (left fuse box, fuse 7) is for the stop and turn lights and the other one is also in the left fuse box, fuse number 12 and is for reverse, licence plate and tail lights.
ImageImageImage
1994 Sovereign Gold 4.0

Area rep. SPAIN
espana.xj40@googlemail.com

jht1776
Posts: 5
Joined: Sun May 08, 2016 10:41 pm

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby jht1776 » Mon Jul 04, 2016 11:12 pm

Thanks , reverse, licence plate and tail lights are working,

jht1776
Posts: 5
Joined: Sun May 08, 2016 10:41 pm

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby jht1776 » Wed Jul 06, 2016 10:02 pm

I want to THANK ALL that helped me with this issue, I double checked fuse # 7 it was not blown, just for the hell of it I replaced it, well guess what all lights are WORKING ............... spent hours and several choice words and it was the fuse ................... THANK YOU !!!!!!!, ........... I have another request if someone could, the covers are missing from my fuse boxes, Please send me a list of what fuses are for what and size (1988 XJ40) Thanks, John

nlcrane
Spain Rep
Posts: 7597
Joined: Sun Feb 07, 2010 7:36 pm
Location: Spain

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby nlcrane » Wed Jul 06, 2016 10:40 pm

jht1776 wrote:I want to THANK ALL that helped me with this issue, I double checked fuse # 7 it was not blown, just for the hell of it I replaced it, well guess what all lights are WORKING ............... spent hours and several choice words and it was the fuse ................... THANK YOU !!!!!!!, ........... I have another request if someone could, the covers are missing from my fuse boxes, Please send me a list of what fuses are for what and size (1988 XJ40) Thanks, John


You have a PM
ImageImageImage
1994 Sovereign Gold 4.0

Area rep. SPAIN
espana.xj40@googlemail.com

naki_k
Super Moderator
Posts: 28341
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby naki_k » Thu Jul 07, 2016 1:59 pm

jht1776 wrote:I want to THANK ALL that helped me with this issue, I double checked fuse # 7 it was not blown, just for the hell of it I replaced it, well guess what all lights are WORKING ............... spent hours and several choice words and it was the fuse ................... THANK YOU !!!!!!!, ........... I have another request if someone could, the covers are missing from my fuse boxes, Please send me a list of what fuses are for what and size (1988 XJ40) Thanks, John


Good result. I often change all the fuses on my cars if the pins look less than perfect. Slight corrosion in them could increase resistance.
Last edited by naki_k on Thu Jul 14, 2016 11:26 pm, edited 1 time in total.
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6 x2
93 6.0 XJ81 XJ12
94 4.0 XJR
94 4.0 Daimler
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

nlcrane
Spain Rep
Posts: 7597
Joined: Sun Feb 07, 2010 7:36 pm
Location: Spain

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby nlcrane » Thu Jul 07, 2016 6:03 pm

Let’s not forget that the amperage rating of a fuse is the point at which it blows should a downstream component fail (short circuit), this chosen amperage is often guess work and is, of course, much higher than the normal operating amperage of the component, so as Naki says, any corrosion on the fuse pins could be enough resistance to inhibit that low normal operational current. Plug in and pull out a few times is invariably sufficient to clean these lugs. Same goes for electrical connectors.
ImageImageImage
1994 Sovereign Gold 4.0

Area rep. SPAIN
espana.xj40@googlemail.com

jht1776
Posts: 5
Joined: Sun May 08, 2016 10:41 pm

Re: 88 XJ6 (XJ40) left turn & break lamps not working

Postby jht1776 » Thu Jul 14, 2016 8:59 pm

I remove all and cleaned with sandpaper , Thanks for the help