• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

Search found 30 matches

by muzz
Fri May 10, 2019 9:15 am
Forum: Suspension
Topic: DIY Steering Rack Rebuild
Replies: 8
Views: 541

Re: DIY Steering Rack Rebuild

I rebuilt my rack as it was leaking a little, I just wanted to see if it could be done.
I have a spare rack hanging in my shed if you are in Sydney.
Easy job if all laid out in order in a clean space, I didn't attempt the pinion seals.
by muzz
Fri May 10, 2019 9:08 am
Forum: Interior
Topic: Erratic Fuel Gauge
Replies: 9
Views: 1396

Re: Erratic Fuel Gauge

The rust on the sender unit is a result of rust in the tank that deposits on the sender unit shaft or pivot point, this is steel.. Did you get yours fixed Bruce69?
by muzz
Sun Oct 28, 2018 6:22 am
Forum: Interior
Topic: Erratic Fuel Gauge
Replies: 9
Views: 1396

Re: Erratic Fuel Gauge

I pulled my sender out of the tank and cleaned of the surface rust, cleaned the contact and changed the rubber gasket, all good now.
by muzz
Sat Oct 27, 2018 10:50 pm
Forum: 86-89
Topic: Fuel gauge sender
Replies: 4
Views: 1110

Re: Fuel gauge sender

I had the same problem in my 89 XJ40, I found that the fuel return line in the tank was not connected to the reserve chamber . there is a chamber in the middle of the base of the tank that holds the fuel ready to be sent to the fuel rail. round, about 20cm high and holds around 1ltr of fuel. All fue...
by muzz
Thu Jan 25, 2018 9:55 pm
Forum: General Chat
Topic: CPS, Crank Sensor again
Replies: 17
Views: 2158

Re: CPS, Crank Sensor again

Code 4 did come up once, I changed the o2 sensor with a spare I had in the parts box and I just found another I can try. do you know the ohms? I am still trying to locate the ecu?? I only run the motor on 92 or even e10 94 I have a complete car I am stripping atm, 1988 rust bucket but lots of parts ...
by muzz
Tue Jan 23, 2018 9:00 pm
Forum: General Chat
Topic: CPS, Crank Sensor again
Replies: 17
Views: 2158

Re: CPS, Crank Sensor again

The girl has not been for a run for about a year, I start her weekly until running temp is achieved and that is it. I changed the sensor today and the same error even after a reset .

The code one only comes up as you are warming up the engine, and there is a drop in rpm and ruff idle begins.
by muzz
Tue Jan 23, 2018 8:52 am
Forum: General Chat
Topic: CPS, Crank Sensor again
Replies: 17
Views: 2158

Re: CPS, Crank Sensor again

I am still having trouble with mine, CHECK ENGINE 1..goes on, is there anything else that may cause this??
by muzz
Thu Sep 14, 2017 9:45 am
Forum: Engine
Topic: "Few" little problems
Replies: 35
Views: 6023

Re: "Few" little problems

I think he sold it? my last job is rack rebuild.
by muzz
Sat Sep 02, 2017 7:13 am
Forum: Suspension
Topic: My New Rack-and-Pinion
Replies: 3
Views: 1048

Re: My New Rack-and-Pinion

Just got my XJ40 1989 rack out and stripped down ready for the new seal kit. Image
The boots had been filled with grease to try and stop the leak.
by muzz
Sun Jul 30, 2017 2:21 am
Forum: 90-92
Topic: Engine Breather Restrictor
Replies: 19
Views: 2633

Re: Engine Breather Restrictor

How is the XJ running now? I noticed a pool of sticky oil residue in my connection to the throttle body. did you have this to?